Jump to content

Kubuntu VS Overclock?


Aerys II
 Share

Recommended Posts

Salute, ho un problema mostruoso che senza dubbio sarà facilmente risolvibile.

Ho un processore Intel e8600 Core 2 Duo da 3,33 GHz overclockato via BIOS a 4GHz (:cool:), ma sorge un grandissimo problema: Kubuntu 9.04 si rifiuta di accettare che la CPU è emancipata e veloce, e di fatto me la fa funzionare ai 3,33GHz di fabbrica. La cosa è molto seccante, perché per il breve periodo in cui su questa macchina c'è stato Winzozz (installato solo per fare appunto verifiche sull'overclock e sulla funzionalità del sistema da chi me l'ha assemblato e overclockato) la CPU correva a 4GHz che era una meraviglia.

Proverò magari a far girare una live di qualche altra distribuzione per scoprire se per caso si tratta di un problema di *buntu, fino ad allora qualcuno ha consigli/idee/suggerimenti? Non posso credere che il processore sia così "lento". Ho controllato le impostazioni di powersave sperando fossero quelle a limitarlo, ma loro non c'entrano, e anzi direi che fanno il loro dovere. Il punto è che da lshw la CPU viene descritta come:

*-cpu:1

physical id: 1

bus info: cpu@1

version: 6.7.10

serial: 0001-067A-0000-0000-0000-0000

size: 3330MHz

capacity: 3330MHz

capabilities: vmx ht cpufreq

configuration: id=1

*-logicalcpu:0

description: Logical CPU

physical id: 1.1

capabilities: logical

*-logicalcpu:1

description: Logical CPU

physical id: 1.2

capabilities: logical

da cui deduco che appunto viene "vissuta" come un processore a 3,33GHz anziché come uno a 4GHz. La cosa mi sconvolge.

Link to comment
Share on other sites


  • Replies 7
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

bumpo che potrei averne bisogno anche io, dato che ho appena comprato un PC con tanto di phenom II X4 che alcuni guru leggendari hanno spinto a 6 GHz... Non voglio di sicuro starmene coi 3 di fabbrica ^^...

Comunque cercherò su internet qualcosa, perché di sicuro ci sarà la soluzione in qualche blog disperso in giro.

Link to comment
Share on other sites

Io ho come l'impressione però che un tempo il monitor di utilizzo del disco fosse più "ottimista" all'inizio, quindi non vorrei fosse in realtà un problema di modulo CPU o che so io: mi fidavo dei miei 4GHz e non ho controllato i primi giorni le prestazioni (avevo mooooooooooooooooooolto da fare ;-)), ma ho come questo terribile dubbio che all'inizio andassero i 4GHz. Mah.

Spulciando in rete ieri sera qualcosa ho trovato, ma alla fin fine parlano di regolare manualmente la frequenza del processore entro un range che ha come estremo superiore quello della frequenza di fabbrica (per le modalità di risparmio energetico e cose così). Ho trovato da qualche parte riferimento a un file di configurazione di una gnome-applet in cui settare il valore massimo, ma non credo influisca sulla frequenza della CPU, piuttosto suppongo si tratti di un parametro dell'applet stessa (una sorta di label o poco via). Altrimenti è praticamente fatta, basta settare lì lo stesso valore dettato in fase di overclock BIOS e pace.

Il problema è che ho i miei dubbi a riguardo.

Link to comment
Share on other sites

inizio a pensare che in realtà sono solo errori di rilevazione della frequenza in effetti... Se il BIOS dice alla CPU che può andare fino a 4GHz non vedo come il kernel linux possa obbligarla ad attestarsi di nuovo alle impostazioni di fabbrica...

È più probabile che il kernel rilevi il processore e ti scriva semplicemente qual'è la sua frequenza di fabbrica fregandosene se realmente va più veloce...

Link to comment
Share on other sites

Io per non saper nè leggere nè scrivere vado a spulciare il sito di Asus per trovare moduli per la scheda madre...

Scusate il doppio post, me lo accorpate? ;-) Danke!

Effettivamente pare sia un problema di rilevamento delle frequenze da parte di Linux (non Kubuntu, proprio Linux: anche Sabayon live rileva il processore a 3,33GHz anziché 4GHz). Ho provato a installare PerlMon, che è considerato un po' l'equivalente GNU/Linux di CPU-Z, ma anche quello mi riporta i valori di fabbrica. La cosa mi pone di fronte a un dubbio: davvero l'overclock viene underclockato in fase di boot da qualche processo a me ignoto, oppure semplicemente PerlMon fa schifo?

Ai posteri l'ardua sentenza.

Link to comment
Share on other sites

L'ho controllato per primo, la frequenza pare essere quella di fabbrica per lui, ma mi segnala percentuali di utilizzo che mi farebbero ben sperare: ho settato il powermanager affinché tenga sempre la velocità al massimo, e comunque le percentuali di cui sopra mi danno uno 0% circa ai 3,33GHz. Che questo significhi che in realtà va sempre a 4GHz?

Allego output:

Spoiler:  
analisi della CPU 0:

modulo acpi-cpufreq

CPU per le quali e` necessario cambiare la frequenza contemporaneamente: 0

limiti hardware: 2.00 GHz - 3.33 GHz

frequenze disponibili: 3.33 GHz, 2.66 GHz, 2.00 GHz

gestori disponibili: conservative, ondemand, userspace, powersave, performance

gestore corrente: la frequenza deve mantenersi tra 2.00 GHz e 3.33 GHz.

Il gestore "performance" puo` decidere quale velocita` usare

in questo intervallo.

la frequenza attuale della CPU e` 3.33 GHz.

statistiche cpufreq:3.33 GHz:0,02%, 2.66 GHz:0,00%, 2.00 GHz:0,01% (1580)

analisi della CPU 1:

modulo acpi-cpufreq

CPU per le quali e` necessario cambiare la frequenza contemporaneamente: 1

limiti hardware: 2.00 GHz - 3.33 GHz

frequenze disponibili: 3.33 GHz, 2.66 GHz, 2.00 GHz

gestori disponibili: conservative, ondemand, userspace, powersave, performance

gestore corrente: la frequenza deve mantenersi tra 2.00 GHz e 3.33 GHz.

Il gestore "performance" puo` decidere quale velocita` usare

in questo intervallo.

la frequenza attuale della CPU e` 3.33 GHz.

statistiche cpufreq:3.33 GHz:0,02%, 2.66 GHz:0,00%, 2.00 GHz:0,01% (1600)

Questo è poi l'output di cat /proc/cpuinfo:

Spoiler:  
processor : 0

vendor_id : GenuineIntel

cpu family : 6

model : 23

model name : Intel® Core™2 Duo CPU E8600 @ 3.33GHz

stepping : 10

cpu MHz : 3330.000

cache size : 6144 KB

physical id : 0

siblings : 2

core id : 0

cpu cores : 2

apicid : 0

initial apicid : 0

fdiv_bug : no

hlt_bug : no

f00f_bug : no

coma_bug : no

fpu : yes

fpu_exception : yes

cpuid level : 13

wp : yes

flags : fp

Su un forum c'è chi dice di aver "tolto dal boot" loadcpufreq e aver risolto. Penso intendano rimuovere ad esempio /etc/rc2.d/S05loadcpufreq.

Questo significa fermare il demone che regola lo scaling, no? Non che me ne faccia granché onestamente (il risparmio energetico lo farò piuttosto coibentando il mondo)... :think:

Link to comment
Share on other sites

Aggiornamento: ho disabilitato su consiglio di un ubuntiano che ha avuto un problema simile la funzionalità per attivare il controllo dello scaling della CPU da parte del sistema operativo, e ora sono sui 4GHz fissi. Non è male ma lo scaling effettivamente non sarebbe male abilitarlo, quindi mi sa che mi toccherà cercare nel bios dove poter impostare valori massimi e minimi per lo scaling stesso.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.